Default windows 'temp' directory prevents Oracle Universal Installer to launch

Today I was by a client to proceed on a delicate TIBCO iProcess upgrade, and I encounter a strange issue : Oracle Universal Installer (9.2.0.1 or 10.2.0.1) won't launch.

If you watch in process explorer, you can see a java process (javaw.exe) launch and die.

I found out that it was the default 'temp' (or tmp) directory that was preventing Oracle Universal Installer to launch.

On this particular machine, the default setting is :

%USERPROFILE%\Local Settings\Temp

which is expanded to (+ oracle path) :

C:\Documents and Settings\matr1x!\Local Settings\Temp\OraInstall2010-05-11_10-08-17AM\jre\bin

I've replaced TEMP and TMP environment variable value by 'c:\temp' and I was able to launch the Oracle Installer and perform the installation.
(using C:\Install\Oracle\client 9i\92010NT_Disk1\install\win32\setup.exe,
C:\Install\Oracle\client 9i\92010NT_Disk1\setup.exe still wasn't working)

Comments

SK said…
Was it the system variable or the User variable that you mentioned you have changed
SK said…
Is it a System variable for User variable that you changed as mentioned in your post for TEMP and TMP?
Manson Thomas said…
Both TMP and TEMP user variables.
Unknown said…
Thanks a lot, solve my problem that I spent 3 days trying to solve and only your solution works.
Anonymous said…
8 years later and your solution helped me install Oracle Client 11 in a corporate Win7 machine. Thank you very much.
Unknown said…
I have facing the same issue from one month, thanks for valuable knowledge sharing... thanks lot..

Popular posts from this blog

Limit the upload bandwidth of your apache webserver with mod_bw

Upgrade Slimframework v3 to v4, how I did it

Reset Bacula database and files